Skip to main content
← All vulnerabilities
CVE-2013-1834GHSA-PRRH-679X-79QH

notes/edit.php in Moodle 1.9.x through 1.9.19, 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows rem

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.8, 2.3.5, 2.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

notes/edit.php in Moodle 1.9.x through 1.9.19, 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated users to reassign notes via a modified (1) userid or (2) courseid field.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 1.9.0 · fixed in 2.2.8

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.5

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.2

References 5

lists.fedoraproject.org

moodle.org

openwall.com

git.moodle.org