Skip to main content
← All vulnerabilities
CVE-2013-1833GHSA-89F3-74M6-G27G

Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.8, 2.3.5, 2.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted filename.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.0.0 · through 2.1.10

  • moodle/moodlePackagist

    From 2.2.0 · fixed in 2.2.8

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.5

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.2

References 5

lists.fedoraproject.org

moodle.org

git.moodle.org

openwall.com