Skip to main content
← All vulnerabilities
CVE-2013-1832GHSA-PGP5-RCWP-QVFG

repository/webdav/lib.php in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 includes the WebDAV p

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.8, 2.3.5, 2.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

repository/webdav/lib.php in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 includes the WebDAV password in the configuration form, which allows remote authenticated administrators to obtain sensitive information by configuring an instance.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.0.0 · through 2.1.10

  • moodle/moodlePackagist

    From 2.2.0 · fixed in 2.2.8

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.5

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.2

References 5

moodle.org

lists.fedoraproject.org

git.moodle.org

openwall.com