Skip to main content
← All vulnerabilities
CVE-2013-1831GHSA-XR24-JP5C-6C4V

lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.8, 2.3.5, 2.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

lib/setuplib.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote attackers to obtain sensitive information via an invalid request, which reveals the absolute path in an exception message.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    through 2.1.10

  • moodle/moodlePackagist

    From 2.2.0 · fixed in 2.2.8

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.5

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.2

References 5

lists.fedoraproject.org

openwall.com

git.moodle.org

moodle.org