Skip to main content
← All vulnerabilities
CVE-2013-1830GHSA-8R7X-QQ55-74V2

user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforpro

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.8, 2.3.5, 2.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforprofiles setting, which allows remote attackers to obtain sensitive course-profile information by leveraging the guest role, as demonstrated by a Google search.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    through 2.1.10

  • moodle/moodlePackagist

    From 2.2.0 · fixed in 2.2.8

  • moodle/moodlePackagist

    From 2.3.0 · fixed in 2.3.5

  • moodle/moodlePackagist

    From 2.4.0 · fixed in 2.4.2

References 5

lists.fedoraproject.org

openwall.com

git.moodle.org

moodle.org