Skip to main content
← All vulnerabilities
CVE-2013-1655GHSA-574Q-FXFJ-WV6H

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via v

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.21, 3.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to "serialized attributes."

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.21

  • puppetRubyGems

    From 3.1.0 · fixed in 3.1.1

References 7

securityfocus.com

lists.opensuse.org

debian.org

secunia.com

puppetlabs.com

ubuntu.com