Skip to main content
← All vulnerabilities
CVE-2013-1397GHSA-7W53-HFPW-RG3G

Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.0-BETA2, 2.0.22, 2.1.7
None on Exploit-DB, Metasploit or GitHub

Summary

Symfony 2.0.x before 2.0.22, 2.1.x before 2.1.7, and 2.2.x remote attackers to execute arbitrary PHP code via a serialized PHP object to the (1) Yaml::parse or (2) Yaml\Parser::parse function, a different vulnerability than CVE-2013-1348.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • symfony/symfonyPackagist

    From 2.2.0-BETA1 · fixed in 2.2.0-BETA2

  • symfony/symfonyPackagist

    From 2.0.0 · fixed in 2.0.22

  • symfony/symfonyPackagist

    From 2.1.0 · fixed in 2.1.7

  • symfony/yamlPackagist

    From 2.0.0 · fixed in 2.0.22

  • symfony/yamlPackagist

    From 2.1.0 · fixed in 2.1.7

  • symfony/yamlPackagist

    From 2.2.0-BETA1 · fixed in 2.2.0-BETA2

References 4

secunia.com

securityfocus.com

symfony.com

exchange.xforce.ibmcloud.com