Skip to main content
← All vulnerabilities
CVE-2013-0333GHSA-XGR2-V94M-RC9G

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.16, 3.0.20
1 on Exploit-DB, 2 Metasploit modules, 1 proof of concept on GitHub

Summary

lib/active_support/json/backends/yaml.rb in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Timeline

  1. Public exploit on Exploit-DB

    EDB-24434

  2. CVE published
  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • activesupportRubyGems

    From 2.3.2 · fixed in 2.3.16

  • activesupportRubyGems

    From 3.0.0 · fixed in 3.0.20

References 15

kb.cert.org

debian.org

support.apple.com

lists.apple.com

groups.google.com

rhn.redhat.com

puppet.com

weblog.rubyonrails.org

Exploit-DB

GitHub · rapid7/metasploit-framework

GitHub · heroku/heroku-CVE-2013-0333