Skip to main content
← All vulnerabilities
CVE-2013-0285GHSA-4936-RJ25-6WM6

The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does not properly restrict casts of string values, whic

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.2, 1.1.4, 1.0.3
None on Exploit-DB, Metasploit or GitHub

Summary

The nori gem 2.0.x before 2.0.2, 1.1.x before 1.1.4, and 1.0.x before 1.0.3 for Ruby does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • noriRubyGems

    From 2.0.0 · fixed in 2.0.2

  • noriRubyGems

    From 1.1.0 · fixed in 1.1.4

  • noriRubyGems

    From 1.0.0 · fixed in 1.0.3

References 2

seclists.org

support.cloud.engineyard.com