Skip to main content
← All vulnerabilities
CVE-2013-0233GHSA-JXHW-MG8M-2PJ8

Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does n

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.3, 2.1.3, 2.0.5, 1.5.4
1 Metasploit module

Summary

Devise gem 2.2.x before 2.2.3, 2.1.x before 2.1.3, 2.0.x before 2.0.5, and 1.5.x before 1.5.4 for Ruby, when using certain databases, does not properly perform type conversion when performing database queries, which might allow remote attackers to cause incorrect results to be returned and bypass security checks via unknown vectors, as demonstrated by resetting passwords of arbitrary accounts.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • deviseRubyGems

    From 2.2.0 · fixed in 2.2.3

  • deviseRubyGems

    From 2.1.0 · fixed in 2.1.3

  • deviseRubyGems

    From 2.0.0 · fixed in 2.0.5

  • deviseRubyGems

    From 1.5.0 · fixed in 1.5.4

References 8

metasploit.com

openwall.com

phenoelit.org

lists.opensuse.org

securityfocus.com

blog.plataformatec.com.br

GitHub · Snorby/snorby

GitHub · rapid7/metasploit-framework