CVE-2012-6109GHSA-H77X-M5Q8-C29H
lib/rack/multipart.rb in Rack before 1.1.4, 1.2.x before 1.2.6, 1.3.x before 1.3.7, and 1.4.x before 1.4.2 uses an incorrect regular express
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.1.4, 1.2.6, 1.3.7, 1.4.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
lib/rack/multipart.rb in Rack before 1.1.4, 1.2.x before 1.2.6, 1.3.x before 1.3.7, and 1.4.x before 1.4.2 uses an incorrect regular expression, which allows remote attackers to cause a denial of service (infinite loop) via a crafted Content-Disposion header.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- rackRubyGems
fixed in 1.1.4
- rackRubyGems
From 1.2.0 · fixed in 1.2.6
- rackRubyGems
From 1.3.0 · fixed in 1.3.7
- rackRubyGems
From 1.4.0 · fixed in 1.4.2