Skip to main content
← All vulnerabilities
CVE-2012-4968GHSA-V358-RVXR-WFFX

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe 2.3.x before 2.3.13 and 2.4.x before 2.4.7 allow remote attackers to inj

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.13, 2.4.7
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe 2.3.x before 2.3.13 and 2.4.x before 2.4.7 allow remote attackers to inject arbitrary web script or HTML via (1) a crafted string to the AbsoluteLinks, (2) BigSummary, (3) ContextSummary, (4) EscapeXML, (5) FirstParagraph, (6) FirstSentence, (7) Initial, (8) LimitCharacters, (9) LimitSentences, (10) LimitWordCount, (11) LimitWordCountXML, (12) Lower, (13) LowerCase, (14) NoHTML, (15) Summary, (16) Upper, (17) UpperCase, or (18) URL method in a template, different vectors than CVE-2012-0976.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • silverstripe/frameworkPackagist

    From 2.3 · fixed in 2.3.13

  • silverstripe/frameworkPackagist

    From 2.4 · fixed in 2.4.7

References 5

doc.silverstripe.org

openwall.com

GitHub · silverstripe/sapphire