Skip to main content
← All vulnerabilities
CVE-2012-3865GHSA-G89M-3WJW-H857

Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise befo

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.17, 2.7.18
None on Exploit-DB, Metasploit or GitHub

Summary

Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in auth.conf, allows remote authenticated users to delete arbitrary files on the puppet master server via a .. (dot dot) in a node name.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    fixed in 2.6.17

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.18

References 9

lists.opensuse.org

GitHub · puppetlabs/puppet

debian.org

ubuntu.com

secunia.com

bugzilla.redhat.com

puppetlabs.com