Skip to main content
← All vulnerabilities
CVE-2012-3465GHSA-7G65-GHRG-HPF5

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/sanitize_helper.rb in the strip_tags helper in Ruby on Rails

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.17, 3.1.8, 3.2.8, 2.3.16
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/sanitize_helper.rb in the strip_tags helper in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attackers to inject arbitrary web script or HTML via malformed HTML markup.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 3.0.0.beta · fixed in 3.0.17

  • actionpackRubyGems

    From 3.1.0 · fixed in 3.1.8

  • actionpackRubyGems

    From 3.2.0 · fixed in 3.2.8

  • actionpackRubyGems

    fixed in 2.3.16

References 4

weblog.rubyonrails.org

secunia.com

rhn.redhat.com

groups.google.com