CVE-2012-3464GHSA-H835-75HW-PJ89
Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.0.17, 3.1.8, 3.2.8, 2.3.16
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inject arbitrary web script or HTML via vectors involving a ' (quote) character.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- activesupportRubyGems
From 3.0.0.beta · fixed in 3.0.17
- activesupportRubyGems
From 3.1.0 · fixed in 3.1.8
- activesupportRubyGems
From 3.2.0 · fixed in 3.2.8
- activesupportRubyGems
fixed in 2.3.16