Skip to main content
← All vulnerabilities
CVE-2012-3463GHSA-98MF-8F57-64QF

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_tag_helper.rb in Ruby on Rails 3.x before 3.0.17, 3.1.x

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.17, 3.1.8, 3.2.8
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_tag_helper.rb in Ruby on Rails 3.x before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attackers to inject arbitrary web script or HTML via the prompt field to the select_tag helper.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 3.0 · fixed in 3.0.17

  • actionpackRubyGems

    From 3.1.0 · fixed in 3.1.8

  • actionpackRubyGems

    From 3.2.0 · fixed in 3.2.8

References 3

weblog.rubyonrails.org

groups.google.com

rhn.redhat.com