CVE-2012-2695GHSA-76WQ-XW4H-F8WJ
The Active Record component in Ruby on Rails before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the passi
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.0.14, 3.1.6, 3.2.6, 2.3.15
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Active Record component in Ruby on Rails before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remote attackers to conduct certain SQL injection attacks via nested query parameters that leverage improper handling of nested hashes, a related issue to CVE-2012-2661.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- activerecordRubyGems
From 3.0.0.beta · fixed in 3.0.14
- activerecordRubyGems
From 3.1.0 · fixed in 3.1.6
- activerecordRubyGems
From 3.2.0 · fixed in 3.2.6
- activerecordRubyGems
fixed in 2.3.15