Skip to main content
← All vulnerabilities
CVE-2012-1987GHSA-V58W-6XC2-W799

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, an

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.15, 2.7.13
None on Exploit-DB, Metasploit or GitHub

Summary

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a Puppet::FileBucket::File object" to write to arbitrary file locations.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • puppetRubyGems

    From 2.6.0 · fixed in 2.6.15

  • puppetRubyGems

    From 2.7.0 · fixed in 2.7.13

References 19

exchange.xforce.ibmcloud.com

puppetlabs.com

projects.puppetlabs.com

ubuntu.com

lists.fedoraproject.org

hermes.opensuse.org

secunia.com

osvdb.org

securityfocus.com

debian.org