CVE-2012-1157GHSA-2X36-7XFM-PGM7
Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.2.2, 2.1.5, 2.0.8, 1.9.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Moodle before 2.2.2 has a default repository capabilities issue where all repositories are viewable by all users by default
Timeline
- CVE published
- Record last updated
Affected versions
- Moodle Moodle
2.2 to 2.2.1+, 2.1 to 2.1.4+, 2.0 to 2.0.7+
- moodle/moodlePackagist
From 2.2 · fixed in 2.2.2
- moodle/moodlePackagist
From 2.1 · fixed in 2.1.5
- moodle/moodlePackagist
From 2.0 · fixed in 2.0.8
- moodle/moodlePackagist
fixed in 1.9.17