Skip to main content
← All vulnerabilities
CVE-2012-1099GHSA-2XJJ-5X6H-8VMF

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.12, 3.1.4, 3.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_options_helper.rb in the select helper in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving certain generation of OPTION elements within SELECT elements.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 3.0.0 · fixed in 3.0.12

  • actionpackRubyGems

    From 3.1.0 · fixed in 3.1.4

  • actionpackRubyGems

    From 3.2.0 · fixed in 3.2.2

References 8

lists.fedoraproject.org

openwall.com

bugzilla.redhat.com

debian.org

groups.google.com

weblog.rubyonrails.org