Skip to main content
← All vulnerabilities
CVE-2012-1098GHSA-QV8P-V9QW-WC7G

Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote atta

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.12, 3.1.4, 3.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in Ruby on Rails 3.0.x before 3.0.12, 3.1.x before 3.1.4, and 3.2.x before 3.2.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving a SafeBuffer object that is manipulated through certain methods.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • activesupportRubyGems

    From 3.0.0 · fixed in 3.0.12

  • activesupportRubyGems

    From 3.1.0 · fixed in 3.1.4

  • activesupportRubyGems

    From 3.2.0 · fixed in 3.2.2

References 6

lists.fedoraproject.org

openwall.com

bugzilla.redhat.com

groups.google.com

weblog.rubyonrails.org