CVE-2012-0878GHSA-27PX-QPMJ-QG38PYSEC-2012-15PYSEC-2026-2859
Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attac
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.0.1, 1.7.5.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Paste Script 1.7.5 and earlier does not properly set group memberships during execution with root privileges, which might allow remote attackers to bypass intended file-access restrictions by leveraging a web application that uses the local filesystem.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- pastescriptPyPI
fixed in 2.0.1
- pastePyPI
fixed in 1.7.5.1