Skip to main content
← All vulnerabilities
CVE-2012-0797GHSA-72GV-QQRP-H9QG

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.2.1, 2.1.4, 2.0.7
None on Exploit-DB, Metasploit or GitHub

Summary

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.2 · fixed in 2.2.1

  • moodle/moodlePackagist

    From 2.1 · fixed in 2.1.4

  • moodle/moodlePackagist

    From 2.0 · fixed in 2.0.7

References 3

git.moodle.org

bugzilla.redhat.com

moodle.org