Skip to main content
← All vulnerabilities
CVE-2011-4924GHSA-VH6G-786F-HXXPPYSEC-2026-3440PYSEC-2026-766

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.7.3, 2.12.22, 2.13.12
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • zope zope2, zope3

    2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1through 3.4.1

  • zopePyPI

    From 3.1.1 · fixed in 3.7.3

  • zope2PyPI

    fixed in 2.12.22

  • zope2PyPI

    From 2.13.0a1 · fixed in 2.13.12

  • zope2PyPI

    fixed in 2.12.22; From 2.13.0a1 · fixed in 2.13.12

References 7

security-tracker.debian.org

bugzilla.redhat.com

access.redhat.com

openwall.com