Skip to main content
← All vulnerabilities
CVE-2011-4625GHSA-5FJ7-F8X3-Q2MC

simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.1
None on Exploit-DB, Metasploit or GitHub

Summary

simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • simplesamlphp simplesamlphp

    1.13.1-2

  • simplesamlphp/simplesamlphpPackagist

    fixed in 1.8.1

References 2

security-tracker.debian.org

mageni.net