Skip to main content
← All vulnerabilities
CVE-2011-4344GHSA-Q3RP-555R-HH6R

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone conta

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.409.3, 1.438
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in Jenkins Core in Jenkins before 1.438, and 1.409 LTS before 1.409.3 LTS, when a stand-alone container is used, allows remote attackers to inject arbitrary web script or HTML via vectors related to error messages.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 1.409.3

  • org.jenkins-ci.main:jenkins-coreMaven

    From 1.410 · fixed in 1.438

References 7

openwall.com

securityfocus.com

cloudbees.com

GitHub · jenkinsci/winstone

secunia.com

groups.google.com