Skip to main content
← All vulnerabilities
CVE-2011-4319GHSA-XXR8-833V-C7WC

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2,

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.11, 3.1.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • actionpackRubyGems

    From 3.0.0 · fixed in 3.0.11

  • actionpackRubyGems

    From 3.1.0 · fixed in 3.1.2

References 9

osvdb.org

openwall.com

weblog.rubyonrails.org

groups.google.com

securitytracker.com

exchange.xforce.ibmcloud.com

securityfocus.com