Skip to main content
← All vulnerabilities
CVE-2011-4301GHSA-JCRJ-GMR6-P5J8

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.9.14, 2.0.5, 2.1.2
None on Exploit-DB, Metasploit or GitHub

Summary

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    fixed in 1.9.14

  • moodle/moodlePackagist

    From 2.0 · fixed in 2.0.5

  • moodle/moodlePackagist

    From 2.1 · fixed in 2.1.2

References 3

moodle.org

git.moodle.org

bugzilla.redhat.com