Skip to main content
← All vulnerabilities
CVE-2011-4299GHSA-H6PX-PVFH-Q2JV

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authentic

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.5, 2.1.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.0.0 · fixed in 2.0.5

  • moodle/moodlePackagist

    From 2.1.0 · fixed in 2.1.2

References 3

moodle.org

git.moodle.org

bugzilla.redhat.com