Skip to main content
← All vulnerabilities
CVE-2011-4298GHSA-8HXM-42V5-66HM

Multiple cross-site request forgery (CSRF) vulnerabilities in mod/wiki/ components in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allow

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.5, 2.1.2
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple cross-site request forgery (CSRF) vulnerabilities in mod/wiki/ components in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allow remote attackers to hijack the authentication of arbitrary users for requests that modify wiki data.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • moodle/moodlePackagist

    From 2.0.0 · fixed in 2.0.5

  • moodle/moodlePackagist

    From 2.1.0 · fixed in 2.1.2

References 3

moodle.org

bugzilla.redhat.com

git.moodle.org